New trigger troubles - Airsoft Sniper Forum
       

Go Back   Airsoft Sniper Forum > General > General Sniper Talk
General Sniper Talk Dedicated to any and all sniper-related discussions

Reply
 
LinkBack Thread Tools Display Modes
Old 11-06-2019, 03:35 PM   #1
Young Gun
 
Join Date: Oct 2019
Location: Scotland
Posts: 2
New trigger troubles

Hi all. I got a new PDI clone trigger for my MB01. I'm having some issues though. When I pull the cylinder back, the small sear that holds the piston until you pull the trigger just loses grip as I'm pushing the bolt back in, basically it doesn't hold at all. I have an Airsoft Pro cylinder and piston set made for the original 90degree trigger so I'm pretty stumped as to why it won't work.

With the cylinder out and triggers attached, I can see the small sear sticks through the housing more with the original one than the new PDI one. Am I right in understanding if I want to use this PDI trigger, I may need to get a PDI piston too? the Airsoft Pro piston and cylinder have around 500 BBs max through them.

any advice would be awesome. Pictures and videos can be provided tomorrow :)
  Reply With Quote
Remove Ads
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -5. The time now is 03:21 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.