Airsoft Sniper Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I have an ics m4 shooting with an m140 spring, apparently the pressure broke the stock hop up, so I put in a metal hop up, now my gun just sounds clogged and when I take the mag off bbs fall out and there is usually a bb in the hop up that didn't go anywhere, I'm using a g&g bucking with a scs and floss mod, it shot great with the stock hop up, now it doesn't.

Anyone know of a way to fix this?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
It's seated properly. No air coming from the bottom entrance hole when I dry fire it, all the air comes out of the barrel.

The original plastic unit broke, I'm guessing due to the high pressure of the 140 spring.

More developements: looks like my bucking is too far back and it's interfering with the bbs entering into the hop up, I pulled it forward a bit but when I put it back in my gun it forces itself back again, I took my outer barrel off and pulled on the inner barrel and it worked for like two shots then went back to being clogged, the bucking is a soft one, should I try a hard bucking?
I any help is appreciated.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
Fixed it! All I did was sand the front of the clip that holds the barrel on, this made the barrel slide forward and boom! Shot my living room wall, success!
(it scared the buhjeezus out of my girlfriend)
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top