Airsoft Sniper Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
274 Posts
Discussion Starter · #1 ·
So, I took apart my Elite Force 1911 to see why it's hop was working so terribly. Somewhere along the way, these 3 pieces popped out, and I have no clue where to put them back:ashamed:. The spring was connected to the nozzle assembly somewhere, but the metal washer and rubber ring seem to have magically appeared when putting the pistol back together. I have some photos attached, and I hope one of the other EF 1911 guys can help me out with this one.
The cylinder follows the barrel/hop assembly, then pops off. It used to slide itself back to reengage another bb, but now it doesn't snap back (you can see the white of the fixed piston head). I know the spring went somewhere in there, but I'm not sure how it stayed in place. The 2nd picture shows how it doesn't snap back.
 

Attachments

·
Registered
Joined
·
274 Posts
Discussion Starter · #3 ·
Thanks so much Wolf! I've never noticed the washers on the spring guide before. That little spring, though >:| Never hated something so tiny with such a passion, trying to get it back into it's housing. You're a lifesaver!
 
  • Like
Reactions: Wolfgeorge

·
Registered
Joined
·
274 Posts
Discussion Starter · #5 ·
Out of curiosity, do you have the Tac version? Your BBU looks different compared to mine. Your spring is retained inside the BBU, while mine rested on a small plastic notch, between the housing and the cylinder, held in place behind a notch in the slide and the cylinder. Held in place by compressive force, which is why I had such a hard time getting it back in. Still, you helped out a lot!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top