Airsoft Sniper Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
So i got this pistol about a year ago now, and its been getting worse. I have 2 so I can verify everything I'm saying. This is a grey edition(not sure if it matters or not) and someone had a short-stroke kit in it when i received it. Its always had this problem with the trigger sometimes not "catching" and not releasing the hammer. Also it will sputter like it didn't get enough gas for the shot and it barely even moves the hammer to the first locking stage. I know for a fact that it's not the mag because 1) its a brand new mag 2) my main 1911 shoots just fine with the mag. I took the stupid short stroke kit out of it as soon as I fired it for the first time. Any suggestions on whats going on?
P.S. Where do i post my intro post.
 

·
Registered
Joined
·
2,872 Posts
I would suggest looking for videos about this, and after you have a decent understanding on how to assemble it, disassemble it and clean the heck out of it.
It is probably just extremely dirty, or a spring is weak.
Start with cleaning every little piece inside to rule out other stuff first.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
I would suggest looking for videos about this, and after you have a decent understanding on how to assemble it, disassemble it and clean the heck out of it.
It is probably just extremely dirty, or a spring is weak.
Start with cleaning every little piece inside to rule out other stuff first.
I did this and t worked because the retainer spring in the rear of the grip, was misplaced/worn. Replaced it and kicks like new again. Thank you
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top