Airsoft Sniper Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I've been having a problem in which the first round in my mag will not feed into my sr25 unil I have pulled the trgger. It is seeming a lot like a psg1. It feeds fine after the first shot being blank, and I don't understand this. Can anyone explain to me why this happens and how to fix it?
 

·
Registered
Joined
·
114 Posts
Have you tried to put a half filled mag in to see if your mag has a problem feeding a full mag.

Sent from my HTC_Amaze_4G using Tapatalk
 

·
Registered
Joined
·
527 Posts
I have a similar problem with my AEG. I can only fill the mag halfway with such heavy BBs, and often the gun will not feed until I remove and reseat the mag.

I have not figured it out myself, but it does seem to correlate with the BB weight. That is I seem to have the malfunction fewer times when I load fewer rounds into the mag. [or if I use a lighter BB.]

For some reason the cheap, crappy, winding mag I have feeds without a problem.
 

·
Registered
Joined
·
384 Posts
How long has this issue been in effect?
 

·
Registered
Joined
·
1,045 Posts
As golden correctly points out, it is just where your nozzle comes to rest when you shot it last.

Its caused by gear over/under spin based around various mechanics going on within the gun that are affected by your set up.

Golden is also sorta correct about the AB MOSFET, depending on how you set it up (if its a variable type) but on most 'dumb' types you'll still experience the same thing.

All you need to worry about is.....

Dont worry about it, its quite normal on a semi only rifle :tup:
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top