Airsoft Sniper Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
297 Posts
Discussion Starter · #1 ·
After trying to get my m24 to work I started to get some new problems. I am positive the sears work fine because 60% of the time the catch and then the bolt becomes extremely difficult to push forward. It will then not go in at the very last centimeter or so. I can pull the trigger and it will jerk into the receiver of the gun and fire. But it occasionally doesn't catch or catches then slam fires. Also I think that the bolt handle is starting to separate from the cylinder. Also it sometimes will catch and I can push it in normally and I pull the trigger and it just wont fire. I have little to no idea of why it keeps doing all of this. Can anyone help me out?
 

·
Registered
Joined
·
228 Posts
I've had the same problem of the bolt being difficult to push forward in my new BAR10, it did this for a few shots then started slam-firing. I would check your piston, see if it can catch your piston sear properly. Also check your piston O-ring and spring guide stopper. Take out the piston O-ring and see if the problem still persists. I've had the bolt not going all the way forward problem, it turned out to be my spring guide stopper.

As for the bolt handle, is there a screw on the very end of it? There is one on my BAR10, and all I had to do was tighten it with an allen key.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top