Airsoft Sniper Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Hey guys, today I noticed my bolt stopped catching, I opened up the trigger box and everything seemed okay. Do you think if I got a zero trigger (Action Army Zero Trigger) that the bolt would catch again?
 

·
Registered
Joined
·
218 Posts
I know from my utg that if I don't pull it "correctly" it doesn't catch... It will be stuck back but I can't push it forward until I nudge it back further.. super annoying..
 

·
Registered
Joined
·
84 Posts
If applicable, what are all the other upgrades that you have applied to your gun? It could possibly be that you bought the wrong piston and the base won't catch with the sear(I've had this problem). If you have taken apart your trigger box before, it could be that you didn't put the two springs that reset the sear in the correct positions. It could also be that your sear has been worn down to the point where it can't catch the piston.

This is kind of a long shot, but how loose is the screw on the back of the bolt? I know that if it's too tight, you can't move the bolt. So maybe if its too loose it won't catch.
This is not possible because the bolt pin/piston lock holds the base of the spring guide in place. Removing the screw entirely and removing the rod might do something to affect the catching of the piston, but even that is unlikely. If it's too tight you might not be able to raise and drop the bolt handle with ease, but the bolt itself should still move.

I know from my utg that if I don't pull it "correctly" it doesn't catch... It will be stuck back but I can't push it forward until I nudge it back further.. super annoying..
I had a similar problem where it got stuck either immediately after pulling the bolt back or halfway when cycling it forward, although it might have been the way I was pulling the bolt back at the time(righty gun, lefty user). To fix this problem I added some lubricant inside the chamber and on the cylinder and it worked beautifully afterwards.
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #7 ·
I definitely think that the sear has been worn down. Ive had the gun for about 9 months and this is the first time it's not catching, I also never took the trigger box apart.
 

·
Registered
Joined
·
84 Posts
I opened up the trigger box and everything seemed okay.
I also never took the trigger box apart.
Huh?

I recommend getting a UTG metal trigger box, which can be bought on amazon for about $30 (works very well) and a steel sear which can be bought from a variety of places (evike, airsoft atlanta, etc.) that would total up to $45-$50 (great deal)
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #10 ·
Haha, I meant that before it stopped catching, I never opened the trigger box up, and after it stopped I did. I will look in to those triggers, thank you.
 

·
Registered
Joined
·
2 Posts
wont catch after upgrade kit

hey guys. i recently bought an upgrade kit for my shadow ops sniper rifle. once i put it in, i was able to shoot it once. i went to shoot again, and this time it wouldn't catch. any suggestions:shrug:?
 

·
Registered
Joined
·
838 Posts
Can you at least look at the date of topic please?
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top