Airsoft Sniper Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Hello population of airsoftsniper forums. I am new to this forums, but not new to airsofting. I've had a few years under my belt
I just recently picked up a maruzen L96 with a ton of upgrades in it, and I'm getting approximately a 10 fps deviation between shots. It may not sound too bad, but it's a bolt action sniper rifle, the deviation should be...well not much. Two of my AEGs have a 2 fps deviation so if an AEG can do it, a bolt action should be able to do it. I'm completely lost now on what more I can do to my L96 to get it have less of an FPS deviation so hopefully you guys can help me with this issue :)

Upgrades done to the L96 (sorry about the prices, I just pulled this from the ad):
PDI:
Hop Unit: $75
6.01 TB: $160
(4) Barrel Spacers: $40

Laylax (First Factory):
Spring Guide: $35
Piston: $45
Piston Head: $ 15
Teflon Cylinder: $141
Cylider Head: $30
Zero Trigger: $235
SP150

Prometheus:
Purple Bucking

"mods" done to the gun:
Teflon taped cylinder head (I get pretty damn near perfect compression) I've tried to push the piston up while plugging the cylinder head and the piston only goes up around 2 cm in the cylinder and stops.
Regreased all the internals with guarder teflon grease (not sure if it's good for this kind of job or not...)
Sorbo padded (not sure if this will do anything to it but probably worth mentioning)

What I think may be the issue:
While I was playing around with the piston inside the cylinder (pushing it up and down), there's one point in the cylinder where the piston gets stuck (like the cylinder narrows and the piston head get's caught on the side). It takes a tiny bit of force to get it past that point and the piston glides smoothly the rest of the way. The point where it gets caught is about an inch down from the top of the cylinder (Top=cylinder head side) and it's only for that tiny spot. I'm thinking about sanding the inside a little bit on that part but figured I should probably ask people with more experience first. So any feedback regarding this topic would be really helpful!! :) Thanks!!!
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #5 ·
oh yea i've seen the two orings. They are in good condition. But for the hopup rubber...it gets pulled off of the barrel when i pull the hopup unit out and is stuck in the hopup unit. Might that be a reason for it?
 

·
Premium Member
Joined
·
3,494 Posts
muntjac13 said:
oh yea i've seen the two orings. They are in good condition. But for the hopup rubber...it gets pulled off of the barrel when i pull the hopup unit out and is stuck in the hopup unit. Might that be a reason for it?
No, that is common when taking the barrel and bucking off of any hop up chamber.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top