Airsoft Sniper Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
iv'e just bought the JG bar 10, and have NOT made any mods yet.

The problem is that i am getting double or triple loading when i cock the rifle? anyone have this issue and know how to solve it?
obviously if i had wanted a shotgun i would have bought one
:(" title=":mad:" border="0"/>

iv'e used .25 and .20 BBs and the problem remains. also i have fiddled about with the hop-up with no success.

any help or suggestions would be great!
thanks in advance
d
 

·
Registered
Joined
·
3,975 Posts
are you sure that you got all the springs back inside the hop up chamber? Right where the bbs load there is a black thing. There should be a small spring on top of that keeping it pushed down.

Not sure what to tell you. As I have not had any troubles with mine. Just make sure that all the springs are there. Could just be a faulty mag as well. You have extra mags or is it the one that came with the rifle?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
yep have reassembled the gun correctly, however the problem remains and started the first time i used the gun before any disassembly had taken place.

i have noticed that if i put alot of upward pressure on the mag during the cycle process it counter acts the problem. also when i adjust the hop up to it max (all the way back toward the trigger)
it also helps. problem there is obviously that the bbs go drastically skyward
:(" title=":mad:" border="0"/>

as suggested the mag may have a fault but it does seem to be in good condition.

as far as i can tell it should be fine, yet here i am looking for advice.

Thx so far, every bit helps!
 

·
Registered
Joined
·
3,975 Posts
You could try to sand the top of the mag off a little bit. Either that or get a few spare mags and see if that will fix it. Because spare mags are only like $12 a pop... so not to much there.

I do know that the VSR mags are a little long to fit in the BAR so some sanding is needed.
 

·
Registered
Joined
·
100 Posts
I would check the spring that attaches to the black part in the hop-up. Your spring might just be too short, or part of the spring could be in the crack of the hop-up. I had to replace my old spring with a cut pen spring that had more resistance.

I just used one of those Bic clickie pen springs.

Have you tried loading just a few BB's in the mag then loading those?

sticks
 

·
Registered
Joined
·
7 Posts
My Sniper, a JG BAR 10 has a problem. When I pull the bolt back it will briefly cock if I hold it back, but then if I let go it snaps forward and doesn't fire. I have taken it apart down to the trigger box and all the internals are brand new. Ive taken it to my local airsoft shop and he said there is nothing apparently wrong with it. Its been in one battle. Please help me!
 

·
Registered
Joined
·
3,975 Posts
Well first off .... Weclome to the fourms.. I suggest that you head over to the introductions and make a thread there.

But as for your rifle I have heard of a few of them having this problem. It could be that your sear isn't ingaging propperly. You said that you haven't taken anything apart? How long have you had the rifle?

Durring your battle did you drop it or bash it on anything? If it is still fairly new.. I would suggest that you contact the company that you bought it from and try to get a new one.
 

·
Registered
Joined
·
7 Posts
I have taken it apart down to the trigger box and nothing seems to be wrong, and ive taken it to my local store and they said theres nothing wrong with it. It wasn't bashed against anything. Its only been in one game and is nearly new minus the fact it doesn't work. Its warranty is up I'm sure because I got it in the beggining of the summer from airsoft gi. How would the sear not engaging be fixed?
 

·
Registered
Joined
·
3,975 Posts
Check around for some pics of the trigger box. There may be a spring that fell out. There should be a part that "pops up" to engage the piston.

Now I haven't actually taken appart my trigger box... but let me see if I can't find you some pics...
 

·
Registered
Joined
·
3,975 Posts
I have looked around and haven't seen any pics of the internals of the trigger box. I would look around for some VSR10 trigger box pictures. As it is a direct clone of the VSR.

Good luck
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top