Airsoft Sniper Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
744 Posts
Discussion Starter · #1 ·
G&G Veteran M14/Leapers 3-9x50

So I was sighting in my m14 at 100 feet. I have my windage adjusted right, but for my elevation I am still 3 mil dots high. Dots over the cross hairs. Hop up is all the way down and I am using ASGI .30's. I am using 44mm objective weaver rings which make my 50mm objective lens sit right on top of the heat shield.

Anyone have any suggestions as to why its shooting high?
 

·
Registered
Joined
·
62 Posts
Yea, check the bucking. My friend's KWA M4 was shooting high and it turned out to be that the bucking didn't seat itself properly into the hop-up chamber. It folded itself in and was pressing pretty hard onto the BB.
 

·
Premium Member
Joined
·
3,494 Posts
First things first, make sure the flight level of your bb is straight before trying to zero. If it is, then possibly what you stated above is a scope problem.
 

·
Registered
Joined
·
744 Posts
Discussion Starter · #5 ·
BB's fly pretty straight other than the few strays. Gun is brand new with a 6.04 tb. I just picked up some taller rings. I'll know in a few days how it shoots and post results.
 

·
Registered
Joined
·
744 Posts
Discussion Starter · #6 ·
Put some BB's through the m14 today with the taller rings. Don't think its shooting high as much as just a big arch. It's got some pretty good range. BB's tend to shoot a little to the left sometimes even with the hop-up turned all the way down. Going to clean the barrel and see if that helps any.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top