Airsoft Sniper Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
536 Posts
Discussion Starter · #1 ·
Hi guys,
I got back from some target shooting fun with my Tanaka M40A1 and this old guy is showing that I was a darn noob back one year ago: the fact that I did not know much about how things worked is reflected in some wear and tear that originated by one simple thing: taking things apart, disassembling, upgrading without knowledge and then trying to reassemble back..

Good thing my SR-15 and the P226 have almost never been tampered with ;) ..but those are not project rifles..so I am assuming I wasn't that "violent" after all ;) it was the good amount of violence.

It definitely helped me understand how to maintain weapons and all their parts..but I have a couple questions about the trigger assembly because lately, even if it's extremely consistent and nice to shoot, the M40A1 tends to slam fire when cocking the bolt..plus the safety was very hard to pull and after a strong pull I managed to get it moving again..only problem is: it does not engage even if it is put in the "safe" position..

Questions:
1) What is the exact function of the three screws on the trigger? I am referring to the ones that face the muzzle and the ones that face the stock, 3 in total. I heard that those might regulate how high the trigger sear or valve knocker is..and that could be the reason of the slam firing.

2) What should I check to see if the safety is engaging properly? Is it supposed to "grasp" and hold the trigger sear?

3) You Tanaka users know that the trigger is held in place on the receiver by two pins. The pin on the back passes through the trigger sear cylinder and holds the "bolt release" lever in place. My question is: is it supposed to be BENT? Mine is definitely bent and I am wondering if that is how it should be.


..maybe I should buy a broken Tanaka rifle to use as spare and finally get things settled down. With the recent air rig installation this thing shoots like an arrow. If I could stop having random problems, I'd say this reached its final stage..but for some reason the old noob violence I put on it is now surfacing back! :)
 

·
Administrator
Joined
·
6,268 Posts
Ahh Tanaka's problems...!
Man I only disassembled the trigger group once, so I can't say much, but if I remember correctly the pins were strait.
Also for the 3 screw you're referring you can find infos about them if you search for KJW M700 manual.
I have it but I'm on vacations and don't have it with me.
If you wait till next Monday I'll sent it to you.


Wolf
 

·
Registered
Joined
·
536 Posts
Discussion Starter · #3 ·
Great help, as usual ;)
I will investigate further and - if anyone knows anything - speak freely ;)

Thanks! (if I had a new Tanaka now I would know how to care more than before.. But no matter how careful I was.. I was way more noobish than I am now..it sort of put its weight on this ;))
 

·
Registered
Joined
·
536 Posts
Discussion Starter · #5 ·
Awesome, thanks. I finally know for sure that one spring is the default amount and not two, although some users reported two in their triggers.

Also, the A and C screws are terribly stuck.. I wonder if they were glued..

I am confident I over pushed the trigger pull and now it's way too short and there makes the whole thing too sensitive and easier to slam fire.

Also, the pins should be straight and not bent..so the one they goes across the bolt stop was bent by brute force Eheh and my safety does not engage properly..argh more maintenance .. But hopefully it will stop one day. ;)
 

·
Registered
Joined
·
536 Posts
Discussion Starter · #10 ·
Eheh ok I will leave the two A and C screws as they are (and were) and only move screw "B" which is the one that adjusts the trigger pull. That is the one I messed with and it screwed me up in exchange (pun intended) eheh.

I hope I didn't destroy my safety..having it move without engaging is not a good sign..
 

·
Registered
Joined
·
184 Posts
I can't even get the middle screw of my AICS to thread back into Part 91, which is probably why my seal sucks. Oh well:p
Have you changed part 91?
I fitted a creations chamber and its slightly out of spec compared to the stock chamber,the screw if a few mm further back(i think),just enough to stop the screw going in properly.

I swapped the mag well and rear screw for a kjw's one which has a bit more flex.
 

·
Registered
Joined
·
536 Posts
Discussion Starter · #13 ·
Don't know if what you asked relates to the problem itself..I have a new
Part 91 and my seal seems ok.. But mine is G&G ..

Anyway I broke my safety and the trigger still slam fires :)

For you PCS owners: does your bolt has a black metal cylinder right behind the PCS screw? It sits inside the bolt, right on the head of the PCS screw..and I have no idea what it is for...

Thanks!
 

·
Administrator
Joined
·
6,268 Posts
I fitted a Creation part 91 in my old AICS and everything except the pins werw drop in. The pins where hammered in!

I've fitted the Best Gun part 91 in my current M700 and also everything is perfect except the fact it uses now only one pin instead of 2!


Wolf
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top