Airsoft Sniper Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello guys, first time posting here (always hesitated to enter these forums since a lot of people seem to be experts, but decided to finally join the forums) , so please forgive me if I make some mistakes.

First of all, after some time saving money, I've got enough to buy upgrades for my vsr10.
The build looks like this:
- Action Army VSR-10 M150 Spring
- Action Army VSR-10 Spring Guide
- Action Army VSR-10 Hop up Chamber
- PDI VSR 10 V-TRIGGER
- PDI Precision Cylinder Set VC for TM VSR 10
- Stainless barrel, 6.01mm, VSR-10, 430mm, PDI
- Maple Leaf Bucking

I don't think there should be much if any incompatibility between these PDI and AA parts. May be wrong.

Anyway, the problem begins as I try to cock the gun. After mounting the whole cylinder and the trigger unit, I tried to cock the gun. It didn't work.
Strange enough, I tried a couple of things to understand where the problem was coming from.
Turns out that the piston sear won't attach to the piston itself when bolting, and therefore the vsr won't cock.
This problem comes as soon as I attach the spring stopper in the cylinder. If I don't attach it I can see how the piston sear will stop the piston and everything feels like is in place.
But as soon as I attach the spring stopper, the piston sear won't stop the piston. It feels so bizarre. Then again, I may be overlooking something.

Any help will be appreciated. Thank you very much!
 
1 - 1 of 1 Posts
Top