Airsoft Sniper Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
I have a friend who got a new gun and he had a UTG MK96 before, and he gave me his two mags. Well these two mags are the standard ones that come with the gun and worked fine when I got them, but one of them has a problem I'm not sure how to fix. When I push down on the plastic part and it goes into the metal base, and doesn't come back out on its own. Its like the spring that pushes it up is broken or something, I'm not really sure what the problem is, because I was able to jimmy it back up with a knife and when I push it down there is still resistance but theres no force to push it back up. Any help/advice would be appreciated :)
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #3 ·
ok i did that (thanks for that advice btw) and I can see now thats its not the spring. This is kind of hard to explain without visuals and I don't have my camera right now but I will try my best. The metal part of the mag surrounds a smaller plastic rectangle that hold all the parts of the mag, it is plastic and the seam that runs down the middle has spread apart and it holds the "pushy-downy" part of the mag against the metal base. I am not sure where to go from here... should I throw some electrical tape around it to hold it together? or super-glue it? or is there another option maybe?
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #5 ·
sweet, thanks for the help, do you think maybe putting a lil bit of grease on the sides would help, or not do anything, or could it stop the mag from working somehow?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top