Airsoft Sniper Forum banner
1 - 20 of 30 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Hello all,
I have had a UTG Mk96 shadow ops sniper rifle for about 6 months now, but it was only operational for 2. My trigger box broke early on, and I recently bought a new one (full metal, but for well MB01). It said it was compatible with the UTG on the website so I bought it, along with the Angel Custom Type 96 SP170 upgrade kit, an SP190 spring, and the rubber piston head. The upgrade kit installed just fine- but I continually had problems with the trigger box. The upgrade kit and trigger box didn't like each other, and when I put the trigger box on, the rod that holds the box to the bolt action kept getting stuck on something when the bolt was being pulled back, stopping it from going back into the normal position and going down again, causing the piston and the spring to become stuck in the chamber. I was able to get it out but they still refuse to work together, not even with the default piston system. I'm pretty sure it's the trigger box, even though they claim it's compatible. But before I hire any services I need to know if there's something I can do about this myself first. I'll post pictures on request, and if there's any other information you need please just ask. Thanks in advance :)
 

·
Registered
Joined
·
157 Posts
It should be compatible since the UTG is made by WELL, however:

You expected an ACM part to work out of the box with an ACM gun... That's not a good practice to get into :p.
 

·
Registered
Joined
·
838 Posts
you need intro post first.

can you give us the link what you buy ?
 

·
Registered
Joined
·
37 Posts

·
Registered
Joined
·
509 Posts
Weird way of saying it but essentially what he is saying is that the tolerances are so weird on acm stuff that it is always a gamble whether it will actually work. Even if it says it will.

Sent from my SCH-I535 using Tapatalk
 

·
Registered
Joined
·
157 Posts
ACM means "all China made". Without looking closer at your issue, you won't fix it by throwing money at it.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #10 ·
Oh. I assumed it was Angel Custom Machining because that's what's on the packaging.. But it's tough stuff I'll say, CNC'd and all that. But right now I just want to make it work again.. Trigger box is the problem. Any suggestions..?
 

·
Registered
Joined
·
838 Posts
where's the spot you got stuck? Take some pictures please.
 

·
Registered
Joined
·
157 Posts
Looks almost like secondary safety (the thing that keeps you from firing when the handle is up) is hanging up.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #14 ·
Oh, I forgot to say- I took the trigger box off. And do you mean that pin? Because that didn't make any significant difference, I think its something to do with the rod that guides that pole inside.
 

·
Registered
Joined
·
157 Posts
Take a picture of the top of your trigger box, I'm not gonna take mine apart
 

·
Registered
Joined
·
157 Posts
Ok, you see that odd-shaped rectangle across from the safety switch? That's what I was referring to.
 
  • Like
Reactions: Anaconda

·
Registered
Joined
·
157 Posts
The short one. The tall one is your spring guide stopper.
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top