Airsoft Sniper Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Hi all, first time poster. I ran into a problem with my buddy's Well MB08 when upgrading it. Got the barrel, hopup and everything installed, but when I put the cylinder parts and the trigger box in, the piston would not engage with the sear unless the spring guide stopper is removed. Once that is taken out it will engage just fine. I'm at a loss for what the issue is. I made sure the piston was able to fully retract onto the guide and spring, and I even removed the bearing at the bottom of the guide but to no avail. The parts used are Matrix/PPS piston, spring, and guide kit, and Atlas Custom Works trigger box. Any help is appreciated.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
I used laylax sorbo pads when initially installing it, I appreciate the suggestions though. Any other thoughts?
 

·
Registered
Joined
·
56 Posts
Hi all, first time poster. I ran into a problem with my buddy's Well MB08 when upgrading it. Got the barrel, hopup and everything installed, but when I put the cylinder parts and the trigger box in, the piston would not engage with the sear unless the spring guide stopper is removed. Once that is taken out it will engage just fine. I'm at a loss for what the issue is. I made sure the piston was able to fully retract onto the guide and spring, and I even removed the bearing at the bottom of the guide but to no avail. The parts used are Matrix/PPS piston, spring, and guide kit, and Atlas Custom Works trigger box. Any help is appreciated.
90 degree sear right? If the sear is not engaging it has to be because the piston is not getting far enough back...the fact you had success with removing the stopper makes me wonder what's causing that.

With my gun, both too long a spring (or using extra adjuster rings) and too strong a spring caused this problem for me. And initially of course a can mod not being cut enough preventing the guide from inserting fully... but you already checked that.
 

·
Registered
Joined
·
92 Posts
Try it with the stock trigger, might be the Atlas after market trigger sear is to far back to catch the piston correctly.

This would explain why it works without the stopper.
 
1 - 7 of 7 Posts
Top