Airsoft Sniper Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
445 Posts
Ok, first you need to make a intro post, second, you need to watch your grammar( like capitalizing your I's). Ok as for your question 1) What wight of BB's are you using, also what is the spring on it. 2) You will need to sand down the mag and mag well, is it painted that could be the problem also some mags for the type 96 are larger then others, it may be e gave you the wrong mag. 3) This one can be a few different things, the BB's could be jamming it, the bolt is getting stuck on something, or the trigger is not in the right place.
 

·
Registered
Joined
·
445 Posts
With my UTG L96 the mag was a little small, because of that the BB's would not feed properly. I am not sure if it would happen the other way around.

As with the BB drop I am not sure what could be causing that. I am not familiar with the edgi kit, so you may want to shoot woogie or fuzzy a pm.

Also your welcome for the help, if you have any other questions just ask or pm me.
 

·
Registered
Joined
·
445 Posts
Oh ok, that's about the range you should be getting with the stock spring, my MB05 gets about 80 90 ft with the stock spring.

As for the mag try sanding the mag well, as well, see if it helps.

If you can get some pic's up on the cylinder head of the gun, as well as the hop-up(what kind are you using). It would greatly help for the bolt problem. Oh one more thing please dont call me sir, it makes me feel old( I know your just being polite, my grandma is from the Philippians and I know all about that stuff).
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top